re = /^s3:\/\/([^\/]+)\/(.*)/
str = 's3://dev-datalake-cluster-bucket-q37evqefmksl/raw/wfm/users.11315'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end