#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+)\.(\d+)\.(\d+)(rc\d+|\.dev\d+)?"
Local $sString = "1.20.0" & @CRLF & _
"1.20.0rc0" & @CRLF & _
"1.20.0.dev0" & @CRLF & _
"1.24.0-git12345678-md5FFFFFFFFFFF" & @CRLF & _
"1.24.0+git12345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")