const regex = /^(\d+)\.(\d+)\.(\d+)(rc\d+|\.dev\d+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)\\.(\\d+)\\.(\\d+)(rc\\d+|\\.dev\\d+)?', 'gm')
const str = `1.20.0
1.20.0rc0
1.20.0.dev0
1.24.0-git12345678-md5FFFFFFFFFFF
1.24.0+git12345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}