$re = '/^(\d+)\.(\d+)\.(\d+)(rc\d+|\.dev\d+)?/m';
$str = '1.20.0
1.20.0rc0
1.20.0.dev0
1.24.0-git12345678-md5FFFFFFFFFFF
1.24.0+git12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);