using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)\.(\d+)\.(\d+)(rc\d+|\.dev\d+)?";
string input = @"1.20.0
1.20.0rc0
1.20.0.dev0
1.24.0-git12345678-md5FFFFFFFFFFF
1.24.0+git12345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}