#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<au>(?<sn>(?: ?\p{L}\.?)+) (?<fn>[\p{L}\p{Pd}]+))"
Local $sString = "1. Delpla I, Jung A-V, Baures E, et al. " & @CRLF & _
"2. De Vrieze J, Smet D, Klok J, et al." & @CRLF & _
"3. Zhang G, Yang J, Liu H, et al." & @CRLF & _
"4. Agdag ON" & @CRLF & _
"5. Zhang F, Hazan Z." & @CRLF & _
"6. Wang Z, Gao M, Wang S, et al." & @CRLF & _
"7. Noori P, Najafpour Darzi G." & @CRLF & _
"8. Rahimnejad M, Ghoreyshi AA, Najafpour G, et al." & @CRLF & _
"9. Lee Y, Martin L, Grasel P, et al." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")