const regex = /(?<au>(?<sn>(?: ?\p{L}\.?)+) (?<fn>[\p{L}\p{Pd}]+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<au>(?<sn>(?: ?\\p{L}\\.?)+) (?<fn>[\\p{L}\\p{Pd}]+))', 'g')
const str = `1. Delpla I, Jung A-V, Baures E, et al.
2. De Vrieze J, Smet D, Klok J, et al.
3. Zhang G, Yang J, Liu H, et al.
4. Agdag ON
5. Zhang F, Hazan Z.
6. Wang Z, Gao M, Wang S, et al.
7. Noori P, Najafpour Darzi G.
8. Rahimnejad M, Ghoreyshi AA, Najafpour G, et al.
9. Lee Y, Martin L, Grasel P, et al.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}