import Foundation
let pattern = #"(?<au>(?<sn>(?: ?\p{L}\.?)+) (?<fn>[\p{L}\p{Pd}]+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1. Delpla I, Jung A-V, Baures E, et al.
2. De Vrieze J, Smet D, Klok J, et al.
3. Zhang G, Yang J, Liu H, et al.
4. Agdag ON
5. Zhang F, Hazan Z.
6. Wang Z, Gao M, Wang S, et al.
7. Noori P, Najafpour Darzi G.
8. Rahimnejad M, Ghoreyshi AA, Najafpour G, et al.
9. Lee Y, Martin L, Grasel P, et al.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)