import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<au>(?<sn>(?: ?\\p{L}\\.?)+) (?<fn>[\\p{L}\\p{Pd}]+))";
final String string = "1. Delpla I, Jung A-V, Baures E, et al. \n"
+ "2. De Vrieze J, Smet D, Klok J, et al.\n"
+ "3. Zhang G, Yang J, Liu H, et al.\n"
+ "4. Agdag ON\n"
+ "5. Zhang F, Hazan Z.\n"
+ "6. Wang Z, Gao M, Wang S, et al.\n"
+ "7. Noori P, Najafpour Darzi G.\n"
+ "8. Rahimnejad M, Ghoreyshi AA, Najafpour G, et al.\n"
+ "9. Lee Y, Martin L, Grasel P, et al.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}