re = /(?<au>(?<sn>(?: ?\p{L}\.?)+) (?<fn>[\p{L}\p{Pd}]+))/
str = '1. Delpla I, Jung A-V, Baures E, et al.
2. De Vrieze J, Smet D, Klok J, et al.
3. Zhang G, Yang J, Liu H, et al.
4. Agdag ON
5. Zhang F, Hazan Z.
6. Wang Z, Gao M, Wang S, et al.
7. Noori P, Najafpour Darzi G.
8. Rahimnejad M, Ghoreyshi AA, Najafpour G, et al.
9. Lee Y, Martin L, Grasel P, et al.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end