$re = '/(?<!A\()\bHello\b/m';
$str = 'Hello hi A(Hello) Hello!';
$subst = "A($&)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;