#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Your Name: (?<name>.+) Date: (?<date>.+) Your Email: (?<email>.+) Your Number: (?<number>.+) Your Requirement: (?<requirement>.+) Website:"
Local $sString = "Your Name: Testing Date: 25/6/2024 Your Email: testing@emaill.com Your Number: 1234567890 Your Requirement: Test Project Name Website:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")