import re
regex = re.compile(r"Your Name: (?<name>.+) Date: (?<date>.+) Your Email: (?<email>.+) Your Number: (?<number>.+) Your Requirement: (?<requirement>.+) Website:", flags=re.MULTILINE)
test_str = "Your Name: Testing Date: 25/6/2024 Your Email: testing@emaill.com Your Number: 1234567890 Your Requirement: Test Project Name Website:"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")