$re = '/Your Name: (?<name>.+) Date: (?<date>.+) Your Email: (?<email>.+) Your Number: (?<number>.+) Your Requirement: (?<requirement>.+) Website:/m';
$str = 'Your Name: Testing Date: 25/6/2024 Your Email: testing@emaill.com Your Number: 1234567890 Your Requirement: Test Project Name Website:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);