import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Your Name: (?<name>.+) Date: (?<date>.+) Your Email: (?<email>.+) Your Number: (?<number>.+) Your Requirement: (?<requirement>.+) Website:";
final String string = "Your Name: Testing Date: 25/6/2024 Your Email: testing@emaill.com Your Number: 1234567890 Your Requirement: Test Project Name Website:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}