use strict;
my $str = 'Your Name: Testing Date: 25/6/2024 Your Email: testing@emaill.com Your Number: 1234567890 Your Requirement: Test Project Name Website:';
my $regex = qr/Your Name: (?<name>.+) Date: (?<date>.+) Your Email: (?<email>.+) Your Number: (?<number>.+) Your Requirement: (?<requirement>.+) Website:/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}