#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^node:.*"
Local $sString = "/path/to/a.txt" & @CRLF & _
"node:path" & @CRLF & _
"node:path" & @CRLF & _
"node:https" & @CRLF & _
"node:http" & @CRLF & _
"node:zlib" & @CRLF & _
"/path/to/b.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")