package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^node:.*`)
var str = `/path/to/a.txt
node:path
node:path
node:https
node:http
node:zlib
/path/to/b.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}