re = /^node:.*/m
str = '/path/to/a.txt
node:path
node:path
node:https
node:http
node:zlib
/path/to/b.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end