using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+-]?(?:\d*[.]?\d+|\d+[.]?\d*)(?:e[-+]?\d+)?";
string input = @"0, +0, -0, 1, +1, -1, 2, +2, -2, 3, +3, -3
.3, 3.14, +3.14159, -3.14159, 0.123, -0.123, .123, +.123
12e+2, 7e-4, 6.3e2, 6.3e+2, 6.3e-2, -6.3e+2, 0.1e-2, +0.1e-2, -0.1e-2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}