use strict;
my $str = '0, +0, -0, 1, +1, -1, 2, +2, -2, 3, +3, -3
.3, 3.14, +3.14159, -3.14159, 0.123, -0.123, .123, +.123
12e+2, 7e-4, 6.3e2, 6.3e+2, 6.3e-2, -6.3e+2, 0.1e-2, +0.1e-2, -0.1e-2';
my $regex = qr/[+-]?(?:\d*[.]?\d+|\d+[.]?\d*)(?:e[-+]?\d+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}