const regex = /[+-]?(?:\d*[.]?\d+|\d+[.]?\d*)(?:e[-+]?\d+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+-]?(?:\\d*[.]?\\d+|\\d+[.]?\\d*)(?:e[-+]?\\d+)?', 'gm')
const str = `0, +0, -0, 1, +1, -1, 2, +2, -2, 3, +3, -3
.3, 3.14, +3.14159, -3.14159, 0.123, -0.123, .123, +.123
12e+2, 7e-4, 6.3e2, 6.3e+2, 6.3e-2, -6.3e+2, 0.1e-2, +0.1e-2, -0.1e-2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}