$re = '/[+-]?(?:\d*[.]?\d+|\d+[.]?\d*)(?:e[-+]?\d+)?/m';
$str = '0, +0, -0, 1, +1, -1, 2, +2, -2, 3, +3, -3
.3, 3.14, +3.14159, -3.14159, 0.123, -0.123, .123, +.123
12e+2, 7e-4, 6.3e2, 6.3e+2, 6.3e-2, -6.3e+2, 0.1e-2, +0.1e-2, -0.1e-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);