import re
regex = re.compile(r"[+-]?(?:\d*[.]?\d+|\d+[.]?\d*)(?:e[-+]?\d+)?", flags=re.MULTILINE)
test_str = ("0, +0, -0, 1, +1, -1, 2, +2, -2, 3, +3, -3\n"
".3, 3.14, +3.14159, -3.14159, 0.123, -0.123, .123, +.123\n"
"12e+2, 7e-4, 6.3e2, 6.3e+2, 6.3e-2, -6.3e+2, 0.1e-2, +0.1e-2, -0.1e-2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")