using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?[^\s?]+\?)([^\s=]+=[^\s&]+)(?:\&([^\s=]+=[^\s&]+))?(?:\&([^\s=]+=[^\s&]+))?(?:\&([^\s=]+=[^\s&]+))?";
string substitution = @" \1\2&\3&\4&\5&o=desc&s=updated";
string input = @"https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults
https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}