import Foundation
let pattern = #"(https?[^\s?]+\?)([^\s=]+=[^\s&]+)(?:\&([^\s=]+=[^\s&]+))?(?:\&([^\s=]+=[^\s&]+))?(?:\&([^\s=]+=[^\s&]+))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults
https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1\2&\3&\4&\5&o=desc&s=updated"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)