package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?[^\s?]+\?)([^\s=]+=[^\s&]+)(?:\&([^\s=]+=[^\s&]+))?(?:\&([^\s=]+=[^\s&]+))?(?:\&([^\s=]+=[^\s&]+))?`)
var str = `https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults
https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated
`
var substitution = " \1\2&\3&\4&\5&o=desc&s=updated"
fmt.Println(re.ReplaceAllString(str, substitution))
}