re = /(https?[^\s?]+\?)([^\s=]+=[^\s&]+)(?:\&([^\s=]+=[^\s&]+))?(?:\&([^\s=]+=[^\s&]+))?(?:\&([^\s=]+=[^\s&]+))?/
str = 'https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults
https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated
'
subst = ' \\1\\2&\\3&\\4&\\5&o=desc&s=updated'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result