# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(7|\+7|8) \(\d{3}\) (\d)\2\2-\d\d-\d\d/\1/gm;t' <<< "+7 (900) 000-90-90"