use strict;
my $str = '+7 (900) 000-90-90';
my $regex = qr/(7|\+7|8) \(\d{3}\) (\d)\2\2-\d\d-\d\d/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";