#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(7|\+7|8) \(\d{3}\) (\d)\2\2-\d\d-\d\d"
Local $sString = "+7 (900) 000-90-90"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)