$re = '/(7|\+7|8) \(\d{3}\) (\d)\2\2-\d\d-\d\d/m';
$str = '+7 (900) 000-90-90';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;