const regex = /(7|\+7|8) \(\d{3}\) (\d)\2\2-\d\d-\d\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(7|\\+7|8) \\(\\d{3}\\) (\\d)\\2\\2-\\d\\d-\\d\\d', 'gm')
const str = `+7 (900) 000-90-90`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);