#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=<path\b[^<>]*)\s*\bfill=(["']).*?\1"
Local $sString = "<svg>" & @CRLF & _
" <g fill="#767676" />" & @CRLF & _
" <path d="M15.7198 19.5836C15.4" fill="#767676" />" & @CRLF & _
"</svg>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")