import re
regex = re.compile(r"(?<=<path\b[^<>]*)\s*\bfill=([\"']).*?\1", flags=re.MULTILINE)
test_str = ("<svg>\n"
" <g fill=\"#767676\" />\n"
" <path d=\"M15.7198 19.5836C15.4\" fill=\"#767676\" />\n"
"</svg>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")