re = /(?<=<path\b[^<>]*)\s*\bfill=(["']).*?\1/m
str = '<svg>
<g fill="#767676" />
<path d="M15.7198 19.5836C15.4" fill="#767676" />
</svg>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end