using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<path\b[^<>]*)\s*\bfill=([""']).*?\1";
string input = @"<svg>
<g fill=""#767676"" />
<path d=""M15.7198 19.5836C15.4"" fill=""#767676"" />
</svg>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}