import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)Value\\s+0:\\s+(?<value0>[^ ]+)Value";
final String string = "Mon Mar 9 14:18:14 2020: Unknown trap (.1.1.1.1.1..1) received from hostname.abcd.com at: \n"
+ "Value 0: hostname.abcd.com\n"
+ "Value 1: 1.2.3.4\n"
+ "Value 2: 11.22.33.44\n\n"
+ "Another sample value is \n\n"
+ "Mon Mar 9 13:38:23 2020: Unknown trap (.1.2.3.4.5.6) received from 19.19.19.19 at: \n"
+ "Value 0: 19.19.19.19\n"
+ "Value 1: 4.4.4.4.4\n"
+ "Value 2: 12.13.14.15";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}