re = /(?ms)Value\s+0:\s+(?<value0>[^ ]+)Value/m
str = 'Mon Mar 9 14:18:14 2020: Unknown trap (.1.1.1.1.1..1) received from hostname.abcd.com at:
Value 0: hostname.abcd.com
Value 1: 1.2.3.4
Value 2: 11.22.33.44
Another sample value is
Mon Mar 9 13:38:23 2020: Unknown trap (.1.2.3.4.5.6) received from 19.19.19.19 at:
Value 0: 19.19.19.19
Value 1: 4.4.4.4.4
Value 2: 12.13.14.15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end