const regex = /(?ms)Value\s+0:\s+(?<value0>[^ ]+)Value/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?ms)Value\\s+0:\\s+(?<value0>[^ ]+)Value', 'gm')
const str = `Mon Mar 9 14:18:14 2020: Unknown trap (.1.1.1.1.1..1) received from hostname.abcd.com at:
Value 0: hostname.abcd.com
Value 1: 1.2.3.4
Value 2: 11.22.33.44
Another sample value is
Mon Mar 9 13:38:23 2020: Unknown trap (.1.2.3.4.5.6) received from 19.19.19.19 at:
Value 0: 19.19.19.19
Value 1: 4.4.4.4.4
Value 2: 12.13.14.15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}