import re
regex = re.compile(r"(?ms)Value\s+0:\s+(?<value0>[^ ]+)Value", flags=re.MULTILINE)
test_str = ("Mon Mar 9 14:18:14 2020: Unknown trap (.1.1.1.1.1..1) received from hostname.abcd.com at: \n"
"Value 0: hostname.abcd.com\n"
"Value 1: 1.2.3.4\n"
"Value 2: 11.22.33.44\n\n"
"Another sample value is \n\n"
"Mon Mar 9 13:38:23 2020: Unknown trap (.1.2.3.4.5.6) received from 19.19.19.19 at: \n"
"Value 0: 19.19.19.19\n"
"Value 1: 4.4.4.4.4\n"
"Value 2: 12.13.14.15")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")