# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/;(?=(?:[^\[\]]*\[[^\[\]]*\])*[^\[\]]*$)
#;|\[|\]//gx;t' <<< "#first split:
gene1[position1:oldAA-newAA;position2:oldAA-newAA;position3:oldXX-newXX];gene2[position1:oldAA-newAA];gene3[v];gene4;gene5
#second split:
gene1[position1:oldAA-newAA;position2:oldAA-newAA;position3:oldXX-newXX]"