#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?x);(?=(?:[^\[\]]*\[[^\[\]]*\])*[^\[\]]*$)" & @CRLF & _
"#;|\[|\]"
Local $sString = "#first split:" & @CRLF & _
"gene1[position1:oldAA-newAA;position2:oldAA-newAA;position3:oldXX-newXX];gene2[position1:oldAA-newAA];gene3[v];gene4;gene5" & @CRLF & _
"" & @CRLF & _
"#second split:" & @CRLF & _
"gene1[position1:oldAA-newAA;position2:oldAA-newAA;position3:oldXX-newXX]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)