import Foundation
let pattern = ##"""
;(?=(?:[^\[\]]*\[[^\[\]]*\])*[^\[\]]*$)
#;|\[|\]
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = ##"""
#first split:
gene1[position1:oldAA-newAA;position2:oldAA-newAA;position3:oldXX-newXX];gene2[position1:oldAA-newAA];gene3[v];gene4;gene5
#second split:
gene1[position1:oldAA-newAA;position2:oldAA-newAA;position3:oldXX-newXX]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)