const regex = /;(?=(?:[^\[\]]*\[[^\[\]]*\])*[^\[\]]*$)
#;|\[|\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(';(?=(?:[^\\[\\]]*\\[[^\\[\\]]*\\])*[^\\[\\]]*$)
#;|\\[|\\]', 'g')
const str = `#first split:
gene1[position1:oldAA-newAA;position2:oldAA-newAA;position3:oldXX-newXX];gene2[position1:oldAA-newAA];gene3[v];gene4;gene5
#second split:
gene1[position1:oldAA-newAA;position2:oldAA-newAA;position3:oldXX-newXX]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);