package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)((?:\S+[\t\r\f ]*){1,3}).*`)
var str = `Examples of three words capture
2 3 5-trifenil tetrazolio cloruro
2-propanol para análisis emsure
2,6-diclorofenol indofenol (sal sódica) p.a.
4 nitrofenil fosfato sal sódica
ablanda carnes
acaí en povo al 70%
aceite de almendras
aceite de canola en polvo
aceite de girasol
aceite de hierbabuena
aceite de inmersión
aceite de menta
aceite de naranja
aceite de parafina
aceite de romero
aceite esencial de árbol de té
aceite esencial de caléndula
aceite hidrosolubre de baobab
aceite mineral
aceite mineral con fragancia almendra`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}