use strict;
my $str = 'Examples of three words capture
2 3 5-trifenil tetrazolio cloruro
2-propanol para análisis emsure
2,6-diclorofenol indofenol (sal sódica) p.a.
4 nitrofenil fosfato sal sódica
ablanda carnes
acaí en povo al 70%
aceite de almendras
aceite de canola en polvo
aceite de girasol
aceite de hierbabuena
aceite de inmersión
aceite de menta
aceite de naranja
aceite de parafina
aceite de romero
aceite esencial de árbol de té
aceite esencial de caléndula
aceite hidrosolubre de baobab
aceite mineral
aceite mineral con fragancia almendra';
my $regex = qr/((?:\S+[\t\r\f ]*){1,3}).*/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}