import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\S+[\\t\\r\\f ]*){1,3}).*";
final String string = "Examples of three words capture\n"
+ "2 3 5-trifenil tetrazolio cloruro\n"
+ "2-propanol para análisis emsure\n"
+ "2,6-diclorofenol indofenol (sal sódica) p.a.\n"
+ "4 nitrofenil fosfato sal sódica\n"
+ "ablanda carnes\n"
+ "acaí en povo al 70%\n"
+ "aceite de almendras\n"
+ "aceite de canola en polvo\n"
+ "aceite de girasol\n"
+ "aceite de hierbabuena\n"
+ "aceite de inmersión\n"
+ "aceite de menta\n"
+ "aceite de naranja\n"
+ "aceite de parafina\n"
+ "aceite de romero\n"
+ "aceite esencial de árbol de té\n"
+ "aceite esencial de caléndula\n"
+ "aceite hidrosolubre de baobab\n"
+ "aceite mineral\n"
+ "aceite mineral con fragancia almendra";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}