# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:\S+[\t\r\f ]*){1,3}).*"
test_str = ("Examples of three words capture\n"
"2 3 5-trifenil tetrazolio cloruro\n"
"2-propanol para análisis emsure\n"
"2,6-diclorofenol indofenol (sal sódica) p.a.\n"
"4 nitrofenil fosfato sal sódica\n"
"ablanda carnes\n"
"acaí en povo al 70%\n"
"aceite de almendras\n"
"aceite de canola en polvo\n"
"aceite de girasol\n"
"aceite de hierbabuena\n"
"aceite de inmersión\n"
"aceite de menta\n"
"aceite de naranja\n"
"aceite de parafina\n"
"aceite de romero\n"
"aceite esencial de árbol de té\n"
"aceite esencial de caléndula\n"
"aceite hidrosolubre de baobab\n"
"aceite mineral\n"
"aceite mineral con fragancia almendra")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.