import Foundation
let pattern = #"((?:\S+[\t\r\f ]*){1,3}).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Examples of three words capture
2 3 5-trifenil tetrazolio cloruro
2-propanol para análisis emsure
2,6-diclorofenol indofenol (sal sódica) p.a.
4 nitrofenil fosfato sal sódica
ablanda carnes
acaí en povo al 70%
aceite de almendras
aceite de canola en polvo
aceite de girasol
aceite de hierbabuena
aceite de inmersión
aceite de menta
aceite de naranja
aceite de parafina
aceite de romero
aceite esencial de árbol de té
aceite esencial de caléndula
aceite hidrosolubre de baobab
aceite mineral
aceite mineral con fragancia almendra
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)